Delayed market prices

Incident Report for Lightyear

Identified

The issue has been identified as originating from the associated exchange. We are in contact with them and monitoring updates.
Posted Apr 13, 2026 - 14:48 UTC

Investigating

We are currently experiencing issues displaying live market prices for EU stocks and UK-listed ETFs. We are investigating the problem and working to fix this.
Posted Apr 13, 2026 - 13:40 UTC