Order status updates delayed for US markets

Incident Report for Lightyear

Resolved

This issue has been resolved.
Posted Dec 22, 2025 - 15:32 UTC

Monitoring

The implemented fix was successful, and all pending updates for US orders have been processed. We're monitoring to ensure that order updates are continuing to be shown consistently.
Posted Dec 22, 2025 - 15:21 UTC

Identified

The issue has been identified, a fix was implemented, and updates for orders placed on US markets are currently processing.
Posted Dec 22, 2025 - 15:17 UTC

Investigating

We are currently investigating a technical issue with our US broker-partner that is preventing updates for orders placed on US markets.
Posted Dec 22, 2025 - 15:00 UTC
This incident affected: Orders.