European market data delay

Incident Report for Lightyear

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 09:21 UTC

Identified

Latest price shown in the instrument page is currently delayed for some European instruments. Order execution price is not affected.
Posted Jun 16, 2025 - 08:33 UTC
This incident affected: Web and Mobile.